Q Tutorial

From Market Research
Jump to: navigation, search

This tutorial provides a basic overview of some of the core functionality of SPSS. Please refer to Data Analysis Software Tutorials for additional background and links to other tutorials.

Importing the data into the software and creating a summary report

  1. Download the example SPSS data file and questionnaire (e.g., to your downloads folder or to your desktop).
  2. Open Q (they provide one month free trials).
  3. Click on File > Import New Data File (New Project) and press Yes.
  4. Press Yes if asked any questions (these questions are asking if you wish to have the data file automatically tidied; this is almost always a good idea). You will now see a table showing the average value of the surveyanalysis::ID Variable.
  5. Select Create > Basic Tables.
  6. Select all the tables on the left and move them across to the Key questions box.
  7. Press OK.
  8. Click on Work Status (on the left). This is the first of the tables containing interesting table. Your screen should now look like the screen below.

QScreen.PNG

Summary tables of grid questions

Grid questions are automatically identified when the data is read into Q. To see an example click on the table (shown on the left) called Grid (by default, Q names grid questions as grid, because the raw data files generally do not contain names for such questions). QGrid.PNG

Creating a crosstab

In this example we will create a crosstab of Unaided awareness by age:

  1. Press SaveTable.PNG, which takes a copy of the current table. We will then modify this copy (this is the basic workflow of Q; tables are created as modifications of existing tables).
  2. Click on the blue menu/box which currently says Grid and select Unaided awareness.
  3. Type age into light brownish menu which currently displays SUMMARY and select Age. Note that interesting results are highlighted (these are the results of automatic statistics tests).
  4. To show the number of observations in each cell of the table, right-click on the table and select Statistics - cells > n.

Filtering the data

Q has a number of different tools for creating the filters. To filter a table to only show the data of males in full-time work:

  1. Press SaveTable.PNG to copy the current table.
  2. Follow the steps in #Creating a crosstab and create a crosstab of Gender by Work status.
  3. Select the cell that corresponds to males in full-time work. (More generally, select the applicable cells.)
  4. Right-click and select Create filter'.
  5. Enter a name of Working Men and press OK. You have now created a filter, but we need to apply it.
  6. Click back on the table showing unaided awareness by age.
  7. Click on the Filter drop-down menu on the bottom left of the screen and select Working Men.

To modify or make a more complicated filter press the yellow F at the bottom left of the screen, right-click and select Edit Variable.

Creating NETs

To produce a of the proportion of people that said they Strongly agree or Agree a little with the statement Technology is fascinating:

  1. Click on the Attitudes table (left of the screen).
  2. Click on Strongly Agree and drag it on top of Agree a little.

Rebasing tables

Re-basing involves recomputing the percentages on the table with some categories removed. In the above example the total sample size is 498 which includes two people that said DON'T KNOW. A more useful calculation of NET AGREE would remove these two respondents. This is done in Q as follows:

  1. Right-click on DON'T KNOW.
  2. Press Remove'.

Charts

A crosstab can be shown as a chart by clicking "Show Data as' (top-middle of the screen) and selecting the desired chart type.

QStackedColumn.png

Changing metadata

This example shows how to change data from appearing as categorical to instead appearing as numeric:

  1. Click on the How many SMS sent in typical week table.
  2. Press the blue arrow to the right of where it says How many SMS sent in typical week.

Data Manipulation > Structure > Average.

Computing minimums, medians and maximums

  1. Select a table that is showing an average (e.g., see the previous section).
  2. Home > Statistics Cells > Median.
  3. Home > Statistics Cells > Minimum.
  4. Home > Statistics Cells > Maximum.

Recoding numeric data

In the above example the range goes from 0 to 200 calls per week with a median of 3. This suggests that only a very small number of respondents have given high ratings and there may be advantage in recoding some of the higher values to lower values (so that they become less influential as outliers. We can do this by;

  1. Select a table containing the data we wish to recode.
  2. Data Manipulation > Data Values > Recode Values.
  3. Replace all the values greater than 50 with the value of 50.
  4. Press OK.

Simple predictive model

This example predicts the number of SMS (text messages) by demographics, assuming that you have recoded the data as numeric (see the previous section):

  1. Insert > Predictive Tree
  2. Select How many SMS sent in typical week.
  3. Select:
    • Work status
    • Occupation
    • Age
  4. Choose Show more patterns.
  5. Press Create Predictive Tree. You should get a tree that looks like this:

PredictTreeExample.PNG

Creating market segments

In this section of the tutorial we will create some market segments using Latent Class Analysis:

  • Create a new page (Insert > Pages > New Page > Table/Chart
  • Insert > Analysis > Groups/Segments

Reporting and sharing results

The report can be exported to PowerPoint, as PDFs, as images and as online reports by clicking the appropriate icons from the ribbon.

ExportingIcons.png

See also

Data Analysis Software Tutorials